Need a perhaps stupid excel help

A place to discuss anything not related to the game.
Post Reply
User avatar
Firefly84
Posts: 278
Joined: Mon Aug 10, 2015 9:23 am
android_version: 8.0
Location: Germany

Need a perhaps stupid excel help

Post by Firefly84 »

I am despairing at a normally easy when...then formular at excel 2010.
I changed a list for work with doctors, their adress and subject (I successful used dropdown and sverweis there).
But then there is the problem with the car use.
I did a dropdown with yes and no but then I need the list to show me the distance driven when the car use is "yes".

Formula used: =WENN(I3="ja";SVERWEIS(B3;Arztbesuche!$A$3:$D$23;4;FALSCH);0)

Sorry, that the formular is in German.
WENN is either if or when
SVERWEIS is VLOOKUP
FALSCH is WRONG

Instead of the distance it only wrote #NV.

I really need help until I have to go to work in 2 hours. :cry:
Firefly
Lvl: 114, PV: 497, FQ: 63
RoLS: 2, ElyR: 1, RoL: 2, HoF: 0, ChaR: 1, GoLF: 1, ShaF: 4, SRoV: 6, VSH: 3, WMC: 1, GoW: 1, BD: 1
DP: 0, X: 0, M: 1, BoGt: 1, SotA: 0, RofLS: 1
HP: 505, AC: 262, AD: 89-105, AP: 4 each, ECC: 12, CM: -, BC: 156, DR: 4

Gonk
Posts: 151
Joined: Mon Mar 04, 2019 8:45 pm
android_version: 8.1 - Oreo

Re: Need a perhaps stupid excel help

Post by Gonk »

Sad, I have no Excel at home.

My strategy in those kind if cases is to break things down in smaller parts and see what is working. Like

=WENN(I3="ja";1;0)

SVERWEIS(B3;Arztbesuche!$A$3:$D$23;4;FALSCH)

You could also post the error message.

One reason for those kind of things not working is when there is a single values expected but sverweis gives multiple values.

User avatar
Nut
Posts: 635
Joined: Mon Oct 27, 2014 12:14 pm
android_version: 5.1 - Lolipop
Location: Glade

Re: Need a perhaps stupid excel help

Post by Nut »

NV means that the sverweis don't find the value of b3 in the column Arztbesuche:a3:a23
Or if this value of b3 is in the list, then the value of Arztbesuche:d... is already NV

Hope this helps - excel is wonderful but sometimes hard to find errors

(Gonk shows a good way to find such errors)
Nut
_____
Lara: Lvl 49, HP 69, AC 229%, AD 28-33, CHS 41, BC 188% Do 6, IF 1, Ce 1, Ev 2, Reg 1, Ta 1, Dp 1, La 1
Conina: Lvl 38, Anwyn[/i]: Lvl 52, Nut: Lvl 61

Post Reply